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Introduction 

The GGMN portal gives insights on the availability of groundwater monitoring data through space and time. 

Groundwater level data and changes occurring in groundwater levels can be displayed on a regional scale. 

Additional data layers and information are available to understand the monitoring data in a broader water-

related context. The web-based software application assists in the spatial and temporal analysis of monitoring 

data. 

Besides the online tools, the GGMN Portal also provides a plugin to work locally on groundwater monitoring 

data using an open source GIS: QGIS. This provides the power and accessibility of desktop applications, while 

still using an online database and online viewer.  
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GGMN Portal 

 

The global map is the ideal starting point for users that want to stroll through the data. It gives a quick insight 

on availability of groundwater monitoring data through space and time, and adds extra data layers and 

information in a broader water-related context.  

 

The regional map gives access to the screen that is focused on analyzing more local sets, to display, mean, 

range and changes of groundwater levels taking a regional perspective.  

 

If the privacy settings are adjusted from public to private (via IGRAC) the time series are visible only after 

logging in. User account and authorization credentials can be obtained via IGRAC. On the top-right of the 

screen the log-in icon is visible. Logging in gives the possibility to see the time series from the organization 

the user belongs to. If you click on your name, you reach the Profile page, where you can change password 

and user information. To log out, you can click on the log-out icon on the top-right side of the page. 

 

A user can be authorized for multiple organizations. With the organization button one can select easily the 

organization to show the data for. This selection is necessary to work with non-public data. 
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Global Portal 

 

On the global map, the data availability and the locations of the measuring stations are visible. A worldwide 

overview gives direct information on the number of countries involved in the GGMN. Time series are visible for 

organisations that accepted to make them publicly available. 

 
 

The data menu can be folded open by selecting the red compass on the top right. Groundwater station 

locations can be displayed on the map by selecting the layer ‘groundwater’. Information on the monitoring 

stations and the corresponding time series are presented by selecting the monitoring station icon on the map. 

A textbox with the station information will be dipalyed. If the time series are publicly available, the time series 

will appear below the information box.  

To obtain an overview of available data in space and time, the map layer ‘availability’ can be selected. Zoom 

in provides more detail where the measuring stations are located. Zooming out to full extent is possible by 

clicking on the compass icon again. By scrolling through the timeline the start and end date of monitoring 

stations can be seen. 

 

 

 

Other layers include Topography, Landcover, Soil, Digital Elevation Model, Aquifers, displaying the 

transboundary aquifers of the world map (IGRAC, 2015) and the WHYMAP layer showing the data from the 

world-wide hydrogeological mapping and assessment program. You can adjust the opacity of the layers by 

sliding the green line beneath the layer box.  
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Regional Portal 

The regional map is focused on analyzing more local sets and to display basic statistics of the groundwater 

levels (mean, range and changes) taking a regional perspective.  

Statistics 

One can see the groundwater data values in two variants: Below Ground Surface (BGS) or Mean Sea Level 

(MSL).   

 Below Ground Surface: These layers show the depth to groundwater below the ground surface 

and are based on water level measurements collected from wells. 

 Mean Sea Level: Groundwater elevations are shown as meter above or below mean sea level 

(positive values indicate groundwater elevations above means sea level, negative values indicate 

groundwater elevations below mean sea level). 

Difference: These layers show changes in groundwater levels over time. Each point shows the calculated 

difference between the measured groundwater levels from the selected time period. The change in 

groundwater level is plotted on the map only if a measurement exists in both time periods at a well.  

 

 

Legend 

The primary scale of the legend is set according to the minimum and maximum of the visualized data. The 

scale can be adjusted by clicking on the bar. A single click adds an extra legend-point; which one can give a 

custom colour by single-clicking it again. A double click removes a legend point. 
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Values on the map 

The values are visualized on the map with coloured dots, according the chosen legend. By hovering above 

the dots, the last value is displayed. By clicking on the dot (monitoring station) a graph with the 

corresponding time series is presented at the bottom of the page. If no data is available, the dots are 

coloured gray. The dots are recoloured when selecting a new parameter, a new period or by changing the 

extent. 

 

Extra layers 

Extra layers can be selected by clicking on the layers-icon. 

 

The layers on the top are the background layers. The transparency of other layers can be adjusted by sliding 

the transparency bar to the left (more transparent) or to the right (less transparent). 

 

 

Spatially interpolated groundwater level data  
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One of the additional layers in the ‘regional map’ view is the “interpolation MSL”. This layers contains a 

spatially interpolated map of groundwater levels in meters above sea level (if developed by the organization). 

More information on the development of spatially interpolated groundwater maps can be found in the 

paragraph ‘GGMN and QGIS’. The colours of the interpolation raster can be scaled, using the minimum and 

maximum value of the raster available in the current extent, by clicking the recolouring-button.  

 

Time series analysis 

  

This tool consists of a time series analysis for groundwater level data followed by analysis of optimal 

monitoring frequency The FREQ tool will consists of the following components 

- Start page 

o Select monitoring well  

o Select time period 

o Graph: original time series 

- Detection of trend  

o Select: no trend, linear trend, or step trend 

o alpha significance 

o graphs: original time series / trend / detrended time series 

- Periodic fluctuations 

o Select: number of harmonics   

o Graph: cumulative periodogram; harmonic series / time series with periodic fluctuations 

removed 

- Autoregressive model 

o Select: correlation lag, order of autoregressive model (p) 

o Graph: serial correlation coefficient vs time lag; result of autoregressive model 

- Additive model 

o Graph: original time series / additive time series model 

- Monitoring frequency 

o Graph: Power of trend detection vs number of observations in a trend detection period. 

 

Select data by clicking on a dot in the map and choosing the parameter to work on. The next steps are 

explained in the information window presented on the online application. During the process of analysis one 

can easily start over by clicking the bin-icon. 
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Import  

 

Groundwater monitoring data can be imported to the GGMN portal via the import screen. To import data, you 

require admin privileges. The import portal consists of two different parts: Import a File and Interpolate a Time 

series. After the station has been uploaded to the portal, you can add the groundwater measurements 

belonging to that station (information on data upload is also available via 

https://ggmn.lizard.net/doc/import_screen.html#upload-assets-as-a-shapefile).  

Upload Groundwater station locations as a shapefile 

Station location and related metadata can be uploaded to the GGMN portal using shapefiles. These 

shapefiles contain information about the station information (assets) and/or meta information on the filter data 

(nested assets). A shapefile can be uploaded as a zipped archive. The zipfile should contain at least a .dbf, 

.shp, .shx and .ini file. All files must have the same name. In case of nested assets (data coupled to a filter), 

this information should be found in the same shapefile record (row) as their assets. The following section 

provides an example of an .ini file for groundwater stations. 

Groundwater stations (no information on filter data) 

An .ini file is used to map shapefile attributes to the GGMN database tables, organisations and attributes. An 

.ini file consists of three sections: 

• [general]: indicates asset name to upload to and optionally organisation uuid. 

• [columns]: maps database columns to shapefile columns 

• [default]: optionally provide default values for columns 

A groundwater station ini file would look like this:   

 

This example .ini creates a new asset from each record of the shapefile, with: 

• A code taken from the ID_1 column of the shapefile; 

• A name taken from the NAME column of the shapefile; 

• A surface_level taken from the HEIGHT column of the shapefile; 

• A frequency that defaults to daily; 

• A scale that defaults to 1, which means this asset can be seen at world scale, when the asset-layer 

in Lizard-nxt is configured accordingly. 

Groundwater station with filter information (Assets with nested assets) 

In case of filter information our multiple filters belonging to the same groundwater station another section 

should be added to the .ini file. A groundwater station with filters (its nested assets) would look like this: 

[general] 

asset_name = GroundwaterStation 

 

[columns] 

code = ID_1 

name = NAME 

surface_level = HEIGHT 

 

[defaults] 

frequency = daily 

scale = 1 

 

https://ggmn.lizard.net/doc/import_screen.html#upload-assets-as-a-shapefile
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The [nested] categories describe: 

 first: indicates the first column in the shapefile that maps lizard columns to shapefile columns. This 

column and all columns to its right configure nested assets. These columns should be a multiple (the 

number of nested assets) of the fields. 

 fields: lizard-nxt fields. Each column in the shapefile (including the ‘first’) is mapped to these fields in 

order, without considering the shape column names. 

This example .ini creates (a) new nested asset(s) from each record of the shapefile, with: 

 A link to an asset that conforms to the asset as described in the Assets without nested assets .ini. 

 A code taken from the 2_code column of the shapefile. And a new nested asset with a 

filter_bottom_level for each 5th column from that column onwards; 

 A filter_bottom_level taken from the column directly next to the 2_code column of the shapefile. And a 

new nested asset with a filter_bottom_level for each 5th column from that column onwards; 

 A filter_top_level taken from the column 2 columns next to the 2_code column of the shapefile. And a 

new nested asset with a filter_top_level for each 5th column from that column onwards; 

 A aquifer_confinement taken from the column 3 columns next to the 2_code column of the shapefile. 

And a new nested asset with a aquifer_confinement for each 5th column from that column onwards; 

 A lithology taken from the column 4 columns next to the 2_code column of the shapefile and each. And 

a new nested asset with a lithology for each 5th column from that column onwards; 

It is possible to add multiple nested assets for one asset. You can copy paste this code in your own .ini file 

and zip it together with the shapefile. 

  

[general] 

asset_name = GroundwaterStation 

nested_asset = Filter 

 

 [columns] 

code = ID_1 

name = NAME 

surface_level = HEIGHT 

 

[defaults] 

frequency = daily 

scale = 1 

 

[nested] 

first = 2_code 

fields = [code, filter_bottom_level, filter_top_level, aquifer_confinement, 

lithology] 

 

https://ggmn.lizard.net/doc/import_screen.html#assets-without-nested-assets
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Import time series (data) as a csv 

Time series can be uploaded through a 4 column csv. Select both the organisation you want to upload and 

the asset type the time series belongs to (e.g. groundwater station). The csv should not contain a header. 

 

timestamp unit id / name value asset id 

2015-01-01T00:00:00Z GWmMSL 248.0 your_own_code_1 

2015-01-01T01:00:00Z GWmBGS 248.0 your_own_code_1 

2015-01-01T00:00:00Z GWmMSL 252.3 your_own_code_2 

2015-01-02T05:00:00Z GWmMSL 234.2 your_own_code_3 

The columns should contain: 

 timestamp: a timestamp in iso8601 format. 

 unit id / name: This is both the name of the parameter referenced unit name and this will become 

the time series name. 

 value: value as either a float or integer number. 

 asset id: either an asset uuid or an organisation-code (an identifier for an asset, unique for your 

organisation). In case the assets have been added with a code under category [columns]. 

Multiple timeseries can be uploaded in one .csv-file, by adding more rows. Since a csv should not contain a 

header, your csv should look like this: 

 

2015-01-01T00:00:00Z GWmMSL 248.0 your_own_code_1 

2015-01-01T01:00:00Z GWmBGS 248.0 your_own_code_1 

2015-01-01T00:00:00Z GWmMSL 252.3 your_own_code_2 

2015-01-02T05:00:00Z GWmMSL 234.2 your_own_code_3 

Example of the content of the time series in a .csv-file. The first column is the date and time of the 

measurement, in ISO 8601 format, 2nd column contains the parameters, 3rd column the value. The last column 

is the code linking the time series to its measuring station. This example shows data for three different 

measuring stations and parameters. 

Export 

 
 

All the data of the GGMN-portal can be downloaded for further use. The data of the selected organization will 

be downloaded to a CSV-file. In the CSV-file the station information and time series data are presented. The 

UUID column can be used to relate the correct time series with the correct station.  

https://en.wikipedia.org/wiki/ISO_8601
https://ddsc.lizard.net/api/v2/parameterreferencedunits/
https://ddsc.lizard.net/api/v2/timeseries/
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GGMN and QGIS 

QGIS is an open source Geographic Information System (GIS), that aims to be user-friendly providing 

common functions and features. This tool is useful for data viewing, editing and analysis. For simple 

interaction between QGIS and the GGMN-database (named Lizard) a plug-in has been developed. The 

GGMN Lizard integration plug-in enables users to download data, add custom ‘virtual’ points (meant for 

interpolation) and upload groundwater interpolation rasters to the database. After uploading, the rasters can 

be seen in the GGMN-portal. 

The plug-in has been tested for QGIS 2.8 (stable version) and QGIS 2.12 (latest version). The screenshots 

used in this manual are from QGIS 2.12. 

 

Installing the plugin 

To install the plugin, go to the menu: Plugins-> Manage and Install Plugins… -> select Settings 

 

 

Click on ‘Add’ under the Plugin-repositories part -> use an applicable name (e.g. Lizard plugins) and type the 

following URL: https://plugins.lizard.net/plugins.xml. Click on ‘OK’ to create the repository. 

 

 

https://plugins.lizard.net/plugins.xml
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Next, select the ‘All’ tab and search for ‘ggmn’.  

 

 

Select the ‘GGMN lizard integration’ plug-in and click on ‘Install plugin’. After installation, the plug-in has been 

added to the Plugins-menu in QGIS. 

Log in 

For downloading the data of your organisation you need to log in. Go to the menu bar, select Plugins-> 

GGMN Lizard integration -> Log into Lizard. 

 

 

 

Insert your Username and Password and click ‘Ok. 
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Download data 

For downloading the data of your organisation you need to log in. Go to the menu bar, select Plugins-> 

GGMN Lizard integration -> Download from Lizard. If you are authorized to see data of multiple organisation 

you can select the organisation you want to download data from. You also have to select a period, by 

choosing a Start date and an End date. The data is download with values in the format ‘mean sea level’. 

 

After clicking OK the plug-in asks to enter a filename for the file to save the data to, e.g. GGMN_download. By 

clicking Ok the data is downloaded and a new layer is added to the QGIS-project. 

 

The new layer is opened in a new QGIS-project, if there is no open project. For each point data is download 

and aggregated to get a single value.  
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To see the values of a location, make sure that the ‘Attributes Toolbar’ is visible (click on View -> Toolbars -> 

Attributes Toolbar if it is unchecked). Then click on the ‘Identify Features’ icon. 

 

 

Next, select a location to see the attributes: 

Name = name as given when uploaded 

Loc_UUID = unique ID of the location (for internal use) 

Ts_UUID = unqiue ID of the time series (for internal use) 

Latitude = the latitude of the location 

Longitude = the longitude of the location 

Min = the minimum of the time series values of the selected period 

Mean = the mean of the time series values of the selected periode 

Max = the maximum of the time series values of the selected period 

Range = the range (difference between maximum and minimum) of the time series values of the selected 

period 
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To get background layers, install plugins like QuickMapServices and select a background-layer. 

 

Custom points 

Custom points are ‘virtual’ measuring point for which one can save values. These values are stored in the 

Lizard backend for the organisation the user belongs to. Before creating or adding custom points, one needs 

to click on ‘Download custom points from Lizard’.  Just like downloading the ‘normal’ points, a file name has 

to be given to save the data to. A new layer is created with the custom points. If there are no custom points 

yet, the layer is empty. 

 

To add a new custom point, click the ‘Add feature’-icon (make sure the ‘Digitizing’ toolbar is displayed) 

 

Click on the location where you want to add a custom point. A popup demands for a value and an internal. 

Enter a value in meters relative to mean sea level. The internal is used for internal QGIS-registration and 

needs to remain NULL. 
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To create multiple points in a simple way, one can choose to use the ‘Regular Points’-tool. Select this tool by 

going to the menu: Vector -> Research Tools -> Regular Points… 

Select a layer of a smaller extent by entering coordinates, the grid spacing and an output shapefile.  

 

Uploading custom points 

For uploading the custom points to the organisation go to the menu bar, select Plugins-> GGMN Lizard 

integration -> Upload custom points to Lizard. A popup message gives the number of points to be uploaded 

and asks for conformation. 

 

 

Interpolation 

An interpolated raster can be created using the QGIS-tools. Select from the menu bar Raster -> Interpolation 

-> Interpolation or click on the ‘Interpolation’-icon on the raster-toolbar. 
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In the popup menu the interpolation input and output can be chosen. First select the layer with the GGMN 

data and select the interpolation attribute (min, max or mean are probably the best to use). Click on ‘Add’ and 

select for example the custom points layer with interpolation attribute value. Also click on ‘Add’. Next, choose 

an interpolation method (e.g. IDW), an extent and an output file for the raster. Click ‘OK’ and the interpolation 

will start and create a new layer. 

 

An example of an interpolation. 
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Upload raster  

For uploading the raster tot the database, make sure the raster file is selected and click Plugins-> GGMN 

Lizard integration -> Upload interpolation raster to Lizard. A message confirms that the upload was 

successful. The raster will be processed and after a short period displayed in the GGMN portal.  

If there was already one raster available for the organisation, the raster will be overwritten.  

 

 

 

 


